NGINX - LUA Module

PerimeterX Bot Defender is designed for high scalability and seamless integration with NGINX. Detection and blocking of all attack types can start almost immediately. Risk scoring and blocking of bad bots is automatic and does not require any dedicated employees to monitor. There is no impact on performance, and there will be a reduction in requests and load to the system with the elimination of bad bot requests.

Supported Operating Systems

  • Debian
  • Ubuntu 14.04 or Ubuntu 16.04+
  • RHEL
  • CentOS 7
  • Amazon Linux (AMI)

Supported NGINX Versions:

It is recommended to use the latest version of NGINX from the Official NGINX repo.

  • NGINX 1.7 or later
  • Lua NGINX Module V0.9.11 or later
  • NGINX Plus
  • Lua NGINX Plus Module
  • OpenResty

Did this page help you?