Fastly Edge Module for Magento2 Installation

Prerequisites

These instructions assume that you have already successfully enabled the Fastly Edge Module in your Magento store. Additional details regarding the Fastly Edge Module can be found here.

For the module to function properly when installed as a Fastly Edge Module, complete the following prerequisites before installing this Magento module.

Installing the Module in Magento

  1. Login to your Magento 2 admin
  2. Navigate to Stores -> Configuration
  3. From the Advanced menu on the left side of the screen, select System
  4. Now, locate and expand Full Page Cache -> Fastly Edge Modules
26262626
  1. To make sure you have the latest version, click the Manage button next to Module Manager
  2. Click the Refresh button to download the latest version of the edge modules
25262526
  1. Scroll down the page and check PerimeterX Bot Defender Integration and click Save at the top of the page.
25482548
  1. To configure the module, click on the gear icon next to the PerimeterX Bot Defender Integration module in the Active Modules list.
17701770
  1. Add your details

📘

Configuration Suggestion

We suggest Monitor mode to start

24782478
  1. Once your details are filled in, click Upload
  2. This deploys the VCL to your Fastly instance
17361736
  1. You should have a new configuration version deployed. Confirm this in your Fastly console
24842484

PerimeterX should now be running


Did this page help you?